2002 Brake light on & rides rough

Gwiz16

Active Member
Two questions : First, I'm searching for any help I can get with my brake light problem. I replaced the rear pads, but the front ones looked pretty good, so I put them back on. Maybe I shouldn't have! The light went out after the job, but returned after a short while. Any suggestions? Second: I replaced the complete suspension, except for both stabilizers bar bushings, the front lower control arms, and the rear shocks and springs. (new shocks & springs up front). Of coarse all of the other rubber boots were a mess, but except for the bad handling, the car's ride was smooth. It handles like a go cart, but it seems it rides kind of choppier! Now I'm only two years in with my Bird, and really don't know what to expect ride wise, only 50K miles, other wise in excellent condition. So hopefully someone can help me with my dilemma. Oh, and I'm running new Michelin's on it. Thanks in advance.
 

biddle

Forum Moderator
Staff member
The brake light questioned was answered back in 2003. The search feature of our site is very useful.

 

Gwiz16

Active Member
For the brake light ..... ABS or Emergency brake ....... You may need to bleed the brakes. In any case you need a code reader. If you use a Maxi Check it has an auto bleed feature. You may need that Auto bleed when servicing the brakes. As for the suspension What did you use? Ford or aftermarket? Was it rubber or poly?
For the brake light ..... ABS or Emergency brake ....... You may need to bleed the brakes. In any case you need a code reader. If you use a Maxi Check it has an auto bleed feature. You may need that Auto bleed when servicing the brakes. As for the suspension What did you use? Ford or aftermarket? Was it rubber or poly?
Thanks Anthony! Ill check with a code reader, get some front brake pads, and thoroughly bleed the bleed the system. Ill also check the ABS module as someone suggested. but if that is my problem, for $400-$500, Ill just deal with the lite. Ill post the fix if and when it happens.
 

Gwiz16

Active Member
Thanks Anthony! Ill check with a code reader, get some front brake pads, and thoroughly bleed the bleed the system. Ill also check the ABS module as someone suggested. but if that is my problem, for $400-$500, Ill just deal with the lite. Ill post the fix if and when it happens.
I apologize Anthony. As to the second problem of a rough ride situation, I used Moog and Monroe parts, torqued to specifications. Not sure if that's the problem.
 
Top