2005 clunks going into park from reverse.

Ron W.

Marilyn's Daddy
Marilyn ( I call her that cause she's a platinum bombshell ) is back home where she belongs.
Took her for a good drive after leaving my mechanic and she's purring fine and running smooth.
The only thing I noticed is when I put her in park after reversing she made a clunk sound. Tried it
a couple of times with same result. She didn't make that sound putting her in park from going forward.
Oh, side note has anyone ever tried to shield the odometer on the dash from sunlight?
terrible glare makes it almost impossible to see.
Thanks all and have a great weekend,
Marilyn's Daddy :)
 

Ron W.

Marilyn's Daddy
The glare from the windshield was bad on my 03, so I bought a dash cover, now no more glare
Yes I realized I would need a dash cover very early on. The problem is the glare on the odometer area in the dash cluster which also shows
what gear you are in. Its so bad most of the time you cant read what it says.
 

Icewine

Well-Known Member
Assuming you are concerned about the speedometer as opposed to the odometer, just drive at whatever speed you’re comfortable with. What are the odds you’ll get a ticket? . Speed limits are artificial concepts that you need not worry yourself with.
 

Icewine

Well-Known Member
Regarding the transmission clunk, what kind of mileage do you have on the car, and what is the maintenance history with regard to the tranny? Has it had the requisite servicing? At this age, it might make sense to have the fluid and filter replaced if it hasn’t been done yet, regardless of mileage.
 

Ron W.

Marilyn's Daddy
Regarding the transmission clunk, what kind of mileage do you have on the car, and what is the maintenance history with regard to the tranny? Has it had the requisite servicing? At this age, it might make sense to have the fluid and filter replaced if it hasn’t been done yet, regardless of mileage.
She had 38K on her when I bought her very recently. The differential had problems and is now fixed and the oil has been changed as well as oil filter. I do need to replace the engine and cabin air filters.. carfax shows only one owner and timely dealer servicing up till 2019. I was just down with her and tried something. Pulled her forward then backed up and put into neutral before I put her in park. No clunk. mechanic will be taking a look and listen next week.
 

tbird.blue

Active Member
She had 38K on her when I bought her very recently. The differential had problems and is now fixed and the oil has been changed as well as oil filter. I do need to replace the engine and cabin air filters.. carfax shows only one owner and timely dealer servicing up till 2019. I was just down with her and tried something. Pulled her forward then backed up and put into neutral before I put her in park. No clunk. mechanic will be taking a look and listen next week.
I've always found that clunkiness occurs on quite a few auto transmissions, on a number of different makes of cars. It helps if in reverse, to initially move shifter back into drive for a moment and then shift to park.
 
Have the backlash rechecked on the drive line. Excessive drive line play in the differential will cause a 'clunk' type sound when the play is removed as the power is transferred to the wheels. Excess play can also cause increased wear and premature failure. of the differential. Setting up a differential correctly is tricky.
Not the best video on the subject, but gives the idea ,,, see the link,.

 
Last edited:

Ron W.

Marilyn's Daddy
@Ron W. use "2005" in your subject instead of "05". This helps with searches & suggested search.

Also, you had asked about the "E code". Does your car have the "E" code? https://forums.fordthunderbirdforum.com/threads/that-pesky-e.3272/post-69037
Will do. And honestly I don't remember asking about the E code but at any rate I have no codes showing up.

Will do. And honestly I don't remember asking about the E code but at any rate I have no codes showing up.
Ahhh yes sorry I did mention it as a comment above mine referred to the dreaded E issue on their 2002 and I was curious
if anyone with a 2005 had experienced it.
 
Top